Problem logging in to Artifik with SMS

Incident Report for Artifik

Postmortem

The initiating procedure for SMS-based logins was rolled back to fix the problem. Furthermore we’ll look at the routines of updating this, adding it to our automated deploy routines to avoid human failure in the future.

We have also set up an alarm for this specific function, so that if the same type of error happens again, we’ll be alerted before any users report the problem to support@artifik.no.

Fallbacks of using Google and password-based login proved useful during this incident. We’ll evaluate if and how we can use the same or similar for any future problems with SMS login.

Posted Mar 06, 2024 - 10:51 CET

Resolved

This incident has been resolved.
Posted Mar 06, 2024 - 10:35 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2024 - 10:06 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2024 - 10:06 CET

Investigating

We are currently investigating this issue.
Posted Mar 06, 2024 - 09:05 CET
This incident affected: Procurement.